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Checking all file types for viruses
File-infecting computer viruses are able to infect only executable files, which are those with 
file extensions of .EXE, .COM, .OV?, and .SYS.    For this reason, The Doctor AntiVirus 
Scanner, by default, checks only these files for viruses.    It is normally absolutely 
unnecessary to check all file types for viruses; doing so slows down the checking process 
dramatically and increases the number of false positives (misidentifications of viruses).    
However, there are two situations in which it may be desirable to check all file types:
1. If a widespread virus outbreak has occurred, i.e., viruses have been found in a 
large number of executable files, you may wish to perform a check of all file types.    Finding
a single virus is not cause to perform a check of all file types.    A small number of viruses 
are able to attach themselves to data files (non-executable files).    This may lead to lost or 
corrupted data in the file, but the virus in this file would pose no threat to the rest of the 
system since it cannot replicate.    The usefulness of checking all file types in this situation 
would be to help locate files corrupted or damaged by the virus, but because of the way 
viruses attach themselves to data files, not all such virus-corrupted data files will be found 
by The Doctor AntiVirus Scanner.    Virus-corrupted data files may or may not be usable.    If 
backup copies of the file are available, it is best to delete the infected file and restore it 
from the backup.    If a backup copy is not available, it is perfectly safe to leave the data 
files on the machine, but do not be surprised if the machine hangs up or acts funny when 
the file is accessed.
2. If any executable files have been renamed and have different file extensions from 
the ones listed above, and if there is the possibility of the files being re-renamed such that 
they once again have an executable file extension, you may wish to check them for viruses 
also.    (This unusual situation should hardly ever arise for the average user).    
          To check all file types, select Check Options from the Options Menu.    In the 
Advanced options box, click on Check all file types.  Clicking the OK button will then 
begin the virus check of all files in the selected path.



Changing the log file name or folder
To change the name and/or folder of the log file, which by default is DOCWIN.LOG in the 
folder in which The Doctor AntiVirus for Windows 95 files were installed, select Options 
from the menu bar.    This will bring up the Doctor AntiVirus Check Options dialog box.  
In the Check results group, the Log file text box shows the present folder and file name 
for the log file.    Change the folder or file name by highlighting the text with the mouse 
cursor and overwriting it.



Checking for viruses on a specific drive
To check a specific drive for viruses, click on the Check Drive button, or select Drive from 
the Check menu.    This will bring up the Doctor AntiVirus- Drive to Check dialog box, 
which contains a list box presenting the drive letters of all available drives.    Click on the 
letter corresponding to the desired drive, and then the OK button to initiate the virus 
check.    The Doctor AntiVirus Scanner will then check those parts of the drive that have 
been selected for checking under Check Options.



Checking for viruses in memory
Since most computer viruses place themselves in the machine's memory area in order to 
replicate, The Doctor AntiVirus Scanner will, by default, automatically first check memory 
every time the program is started.    To have the Scanner avoid checking memory the next 
time it is started, unmark the Check memory check box in the Advanced options group 
of the Check Options dialog box under the Options menu.



Checking for viruses in a specific folder
To check for viruses in a specific folder, click on the Check Folder button on the Main 
screen, or select Folder from the Check menu.    This will bring up the Doctor AntiVirus- 
Folder to Check dialog box.    The full path name of the folder presently selected for 
scanning will appear in the text box at the top of this dialog box.    Click on the letter of the 
desired drive in the list box in the lower-left corner of the dialog box, and double-click on 
the name of the desired folder in the larger list box above.    The text box at the top of the 
dialog box will change to reflect the folder currently selected for checking.    Click the OK 
button to begin the virus check.



Checking for viruses in all subfolders
When a drive or folder is selected for checking, The Doctor AntiVirus Scanner will, by 
default, check all subfolders of that folder for viruses.    To avoid checking subfolders, 
unmark the Scan subfolders check box in the Advanced options group of the Doctor 
AntiVirus Check Options dialog box, which is located under the Options menu.



Configuring checking options
Select Check Options from the Options menu to bring up the Check Options dialog 
box.    This dialog box allows you to configure what will be checked, what actions will be 
taken by the program if a virus is found, and the name of the log file generated by the 
program.
If virus found options:
      Three mutually exclusive choices appear in this group.    If Report only is selected,    The
Doctor AntiVirus Scanner will identify the name of the virus and the place where it was 
found but will make no effort to remove the virus.    This information will be written to the 
log file.    If Prompt before cleaning virus is selected, the program will pause when a 
virus is detected and ask the user if it should try to remove the virus.    If Automatically 
clean virus  is selected, the Scanner will attempt to remove any viruses it encounters.    A 
message will appear indicating whether the attempt was successful or not.    Unfortunately, 
not all viruses can be cleaned; some file-infecting viruses completely destroy the file which 
they have infected.    In this case the file must be deleted in order to eliminate the virus.
Advanced Options:
      This group contains three options pertaining to what will be checked by The Doctor 
AntiVirus Scanner.    If Check subfolders is selected, all subfolders beneath the presently 
selected parent folder will be checked for viruses.    If Check all file types is selected, all 
files, regardless of their file extensions, will be checked for viruses.    (This is normally not 
necessary; see Checking all file types for viruses).    If Check memory is checked, the 
Scanner will check memory for viruses each time it is started.
Check results:
      The log file stores information about the most recent virus check performed by The 
Doctor AntiVirus Scanner.    The default name for the log file is DOCWIN.LOG, and its default
location is in the same folder from which The Doctor AntiVirus for Windows 95 is being run.  
To change the log file name or its location, highlight the text in the Log file text box and 
enter the desired file name and path.    To change the Maximum size of log file, use the 
arrow icons next to the number, or highlight the existing number with the mouse cursor 
and overwrite the existing number    (the size is expressed in kilobytes).
Reset to Defaults:
      Clicking this button will restore the default virus checking configuration.    By default, the
Scanner will check memory and all executable files in the presently selected folder and its 
subfolders, and viruses will be reported and written to the log file, but not removed.    



Exiting The Doctor AntiVirus Scanner
The recommended method of quitting The Doctor AntiVirus Scanner is to select Exit from 
the File menu.    



Printing the Log File
To send a copy of the Log file to the printer, select Print Log File from the File menu.    
This will bring up a standard print dialog box.    Select the desired options and click the OK 
button to begin the printing.    



Removing a detected virus
In addition to detecting viruses, The Doctor AntiVirus Scanner is able to clean (remove) 
many of the viruses it finds.    If you wish for the Scanner to clean any viruses it finds, select
Automatically clean virus in the If virus found group of the Doctor AntiVirus- Check 
Options dialog box in the Options menu.    With this option selected, the Scanner will 
automatically attempt to remove any virus that it finds.    When a virus is detected, a 
message will be displayed showing the name of the virus, where it was found, and whether 
or not it can be cleaned by the Scanner.    When the virus clean is attempted, a message 
will be displayed telling whether the clean attempt was successful.
If The Doctor AntiVirus Scanner cannot clean the virus:
          If the virus is a boot sector-infecting virus, see Removing a boot sector virus.
          If the virus is a file-infecting virus, see Removing a file-infecting virus



Getting technical support
See About in the Help menu for information about technical support for this product. 



Viewing the known virus list
To see a list of the viruses which the present version of The Doctor AntiVirus Scanner will 
detect, select Known Virus List from the View Menu.    It will take the program a few 
seconds to generate the alphabetical list of viruses.    Use the scroll bar at the right edge of 
the list box to examine the virus list 
The names are those used by Thompson Network Software.    There are no universally 
recognized conventions for the naming of viruses;    five different anti-virus products may 
each identify the same virus by a different name.    To further complicate matters, the same 
name may be used for different viruses by different anti-virus products.
In the known virus list, following the name of the virus appears, in parentheses, any other 
commonly used names for the virus.    These alternate names, called "aliases", may be used
as the primary name by other anti-virus products.
Thompson Network Software updates The Doctor AntiVirus for Windows 95 monthly to 
include signatures for the newest viruses we have received.    The updates are available to 
registered users via our BBS (See Getting Technical Support).



Checking for viruses on all hard drives
To have The Doctor AntiVirus Scanner check all local hard drives for viruses, click the 
Check All Hard Drives button, or select All Hard Drives from the Check menu.    This 
operation will always check all subfolders on the hard drives, regardless of whether the 
Check subfolders check box has been selected under Options. 



The Doctor AntiVirus Scanner
The Doctor AntiVirus Scanner is the user-configurable virus-scanning component of The 
Doctor AntiVirus for Windows 95.    The Doctor AntiVirus Scanner looks for computer viruses 
in files, boot sectors, and memory areas by searching for distinct sequences of bytes called 
virus signatures.    If a virus signature is found, a virus is probably present.    The Doctor 
AntiVirus Scanner contains signatures for thousands of known viruses.    To see the names 
of the viruses found by the present version of The Doctor AntiVirus for Windows 95, select 
Known Virus List from the View menu.
When a virus is found, The Doctor AntiVirus Scanner alerts you of its presence by displaying
a message and can, in many cases, remove the virus.



Basic Operation of The Doctor AntiVirus Scanner
Using The Doctor AntiVirus Scanner should be easy and largely self-explanatory for anyone 
familiar with the standard Windows interface.    The Scanner uses the customary drop-down 
menus, dialog boxes, and command buttons that are characteristic of the Windows 
environment.    Rather than presenting the user with a confusing variety of options, the 
Scanner can be run with just a few button clicks requiring only a minimal amount of 
explanation.
Just decide what areas you want to check for viruses, and click the corresponding buttons.   
Click Check All Hard Drives to check all hard drives for viruses; click Check Drive to 
check a specific drive, or click Check Folder to check a specific folder.    Use the Check 
Options dialog box to customize the checking process.
By default, the Scanner will check the computer's memory area to see if any viruses are 
prsent in memory each time the program is started.    Then the boot sectors on either the 
computer or the diskette, whichever is being checked, will be checked for viruses before 
files on the selected drives are checked.
If any viruses are found, a message will be displayed identifying the name of the virus and 
where it was found.    Many viruses can also be removed.



Removing a boot sector-infecting virus
If your computer has a boot sector-infecting virus and The Doctor AntiVirus Scanner cannot 
clean it, do the following to remove the virus:
1.    Boot the machine from a write-protected bootable diskette which is known to be free of 
viruses.
2.    Run the DOCTOR.EXE program from your original Doctor diskette.    This is the earlier 
DOS version of The Doctor AntiVirus program.    Use the DOS Doctor to remove the boot 
virus.



Removing a file-infecting virus
If The Doctor AntiVirus Scanner is unable to clean a file-infecting virus, the infected file 
must be deleted in order to eliminate the virus.    This emphasizes the importance of 
making regular backup copies of the files on your machine.    If backup copies are available, 
recovery from a file-infecting virus outbreak will usually be quite simple; just restore the 
deleted infected files from the clean backups.



The Doctor AntiVirus Monitor

The Doctor AntiVirus Monitor is the real-time virus scanning component of The Doctor 
AntiVirus for Windows 95.    It is installed as part of the default installation of The Doctor 
AntiVirus for Windows 95 and will be activated the next time Windows 95 is started on the 
computer.    The Monitor watches for viruses in programs and on diskettes as they are 
accessed by Windows 95, and alerts you if one is found by displaying a message.    Also, by 
default, the program automatically checks the computer's memory area for viruses each 
time Windows 95 is started.    
When the Monitor is activated, a stethoscope icon will be placed in the Windows 95 task 
bar.    The Monitor's real-time virus scanning can be turned off (see below); when it is turned
off, the stethoscope will have the red "No" symbol superimposed across it. 
Normally the Monitor quietly watches for viruses in the background while you use your 
Windows 95 applications, unless a virus is detected, in which case the main window pops 
up to display the warning message.    However, you can bring up the main window in order 
to configure the program by clicking on the stethoscope icon. 
The Doctor AntiVirus Monitor main window consists of the last warning message box and
five command buttons: OK, Disable/Enable, Repair, Options, and Help.    At the top of 
the main screen appears the version number of the software.
The last warning message box shows the last warning message displayed by The Doctor 
AntiVirus Monitor.    Of course, this box will be empty if no viruses have been found since 
the Monitor was installed.    The warning message consists of two parts: 
1.    The first part identifies the last virus detected by The Doctor AntiVirus Monitor and 
where it was found.
2.    The second is a user-configurable message.    By default, it reads "A virus has been 
found in the above location.", but it can be customized to display information about who to 
contact in case a virus is found, or any other special instructions that may be desirable.    
See The Doctor AntiVirus Monitor Options for instructions on how to change this message.
The OK button closes The Doctor AntiVirus Monitor main window and restores it to the 
taskbar.    
The Disable/Enable button toggles the real-time scanning of the Monitor between on and
off.    When this button is labelled Disable, real-time scanning is on and clicking the button 
will turn off real-time scanning.    When the button is labelled Enable, real-time scanning is 
off and clicking the button will turn on real time scanning. 
The Repair button will cause The Doctor AntiVirus Monitor to remove the virus (if 
possible).    (Note: the ability to remove viruses from files is not available in the shareware 
version)
The Options button brings up The Doctor AntiVirus Monitor options dialog box.
The Help button brings up the on-line help screen. 



The Doctor AntiVirus Monitor Options

Click on the Options command button on The Doctor AntiVirus Monitor main window to 
configure the program.

Objects to check group
          Floppy boot records when accessed- if this check box is checked, any time 
Windows 95 accesses a diskette, the boot sector of the diskette will be checked for viruses 
by The Doctor AntiVirus Monitor.
          Programs when executed- if this check box is checked, programs will be checked 
for viruses as they are executed.
          Memory during initialization- if this check box is checked, the computer's memory 
area will be checked for viruses when Windows 95 is started. 
By default, each of these options are turned on. 

Customized warning message
If The Doctor AntiVirus Monitor finds a virus, the warning messages will be displayed.    The 
second part of the warning message is a configurable one; to change it, highlight the text 
displayed in the Customized warning message text box and overwrite it by typing in 
the desired message. 
Click the OK button when you are finished configuring The Doctor AntiVirus Monitor 
Options.    The Cancel button closes the Options dialog box without saving any 
configuration changes. 



Uninstalling The Doctor AntiVirus for Windows 95

To uninstall The Doctor AntiVirus for Windows 95 select Add/Remove Programs from the 
Windows 95 Control Panel.    Highlight Doctor AntiVirus in the remove list box and then 
click the Add/Remove button.    Once the uninstaller completes The Doctor AntiVirus for 
Windows 95 will be completely removed from the system.



Viewing the log file

To view the log file, select Log File from the View menu.    This will bring up The Doctor 
AntiVirus Check Results dialog box, which displays the log file.

The log file stores information about virus checks performed by The Doctor AntiVirus 
Scanner, and also records virus detections made by The Doctor AntiVirus Monitor.    Each 
time the Scanner is run, an entry will be added to the log file whether any viruses were 
found or not.    For each virus check, the following information will be recorded in the log 
file:
          The beginning time and date of the virus check
          The number of files checked
          The number of viruses found
          The name of any viruses found and the place where they were detected
          The ending time and date of the virus check
Entries in the log file are in reverse chronological order (the most recent entries are at the 
top of the file). 
The log file will grow until it reaches a maximum size.



Changing the log file's maximum size

The log file has a default maximum size of 100 kilobytes.    As new entries are appended to 
the log file, it will be allowed to grow to the maximum size, at which time older entries will 
be truncated.    To change the maximum log file size, select Options from the menu bar.    In
the Check results box, change the Maximum size of file (in Kilobytes) either by 
highlighting the existing number with the mouse cursor and overwriting it, or by using the 
up and down arrow buttons next to the number.    The maximum maximum size of the log 
file is 512 kilobytes.    




